Access Wago PFC200 WDA OpenAPI

I’m currently attempting to request data from the Wago WDA API but am constantly getting a bad request or timeout.

The documentation refers to the hostname/wda on port 443

Looking at our /etc/services I find that port 443 is the HTTPS port:

I’m also able to grab the openapi json string in the documentation via

I’ve set the GET HTTP request settings to point to the port and file wda:

I’ve tried with and without authentication with no success. The Authentication parameters I’ve used are the login and password for ssh/wbm connection (root,wago).

I still receive these errors from the GET command and am unsure why:

As a last ditch effort, I’ve disabled the firewall for HTTPS and ensured that the service is enabled but still nothing.

Does anyone have any ideas on the correct configuration to access the API?


Have you tried with admin/wago ?

Hi Quentin, I just tried it with the same error.

Hi @joe_a , I guess this is probably because of self signed certificate.
Your client probably doesn’t like this.
Using Insomnia software, you can disable certification validation, and then it works.

You can find the software here :

Quentin, you’re exactly right! For some reason my Node-Red instance demands that I have TLS/SSL connection and then I’d have to disable the verifying certification field.


I’m wondering if this is because I’ve been playing around with OpenSSL certs on my PFC lately :smile:

Thanks again for the help!

Even without playing I guess the client doesn’t like the self-signed certificate.
It’s just like the warning you get when you access the webserver.