How to enable HTTP services outside of WBM


I’ve a new PLC (750-8210) and I can’t connect to the webpage as the/our firewall blocks it. Other PLC’s do work, but they have HTTP services enabled as the HTTPS gets blocked. However, I can connect to the plc via filezilla/wago ethernet settings and I’ve upgrade the FW to 25.

Is there another way to enable HTTP services besides the WBM? Like there’s a config file on the PLC which I can update to enable this. Or by using a standard wago software package.

Thank you!

you can try the cbm via Linux console:


Hi Patrick,

Thanks for your quick response, very much appreciated. I managed to get into the console WBM with that.

However, the version of my console wbm has fewer options (6) and not including the ports and services.

I’ve tried to connect to the PLC via the webbrowser via work and private laptop, in both cases the connection is refused. So it doesn’t seem firewall/vpn related on the laptop.
Also using the Wago cable (which is inserted under the SD card slot) doesn’t work.

I have gone back to factory settings (as I installed FW25 earlier), but no luck.

Do you have any other suggestion which I can try?

Try the following command line

/etc/config-tools/config_port port=http state=enabled

1 Like

@quenorha Thanks for helping out. I tried your command, but I don’t think it worked as planned:

I see I misspelled (port-value=http instead of port=http). But still no access to WBM.

hello, what is your FW version ?
It seem you where trying the FW25 but had rolled back to another one ?

Edit: can you check this command:
/etc/config-tools/config_ssl http-status

if disabled try:
/etc/config-tools/config_ssl enable-http

Hi @WagoIcard ,

You are the winner.
I did two things:

  • enabled the http with the config_SSL as you mentioned (and wago support)
    Status http poort: “./config_ssl http-status”
    Enable http poort: “./config_ssl enable-http”
    Disable http poort: “./config_ssl disable-http”

Finally, I upgrade from FW25 to FW26 and it seems to work. I can connect to WBM and the HTTP was enabled as expected. I wonder if the previous upgrade for FW25 was 100% correct, but it works now.
I did not want to go to FW26 initially, as storing data on the SD card needs a workaround. So i’ll set that up.

Thanks a lot for all your help!

You can still downgrade to FW25 if you want to try again.
Also you can try using an SD card to boot on another FW version for testing.