Custom route/Port forwarding

I have a setup like described in the picture, my engineering PC is connected to X2 connector of my Wago PLC. Then there’s on IOT module, running an UI application on top of Node Red (port 1880), connected to X2. I would like to route the etherhet traffic through the PLC, so that I can see the UI with my engineering PC. Is that possible? I have tried many to accomplish it by tweaking the ‘Custom Route’ and ‘Port Forwarding’ setting in WBM, but no success so far.


try using network=host for the docker container.

I’m not running Docker.

I’m assuming you’re using two Windows-based computers. If not, some of this post does not apply.

1)Enable “IP-Forwarding through multiple interfaces” in the PFC200 WBM.

2a) Run “cmd” as the administrator on the IoT Computer
2b) Execute the command “Route ADD Mask”.

3a) Run “cmd” as the administrator on the Engineering PC
3b) Execute the command “Route ADD Mask”.

The Engineering PC should be able to communicate with the IoT Computer now.

1 Like

Yes, that does it! Thanks a million!
My IoT device is actually a Raspberry Pi like Linux device, so the first command needed to be “ip route add via”

1 Like

I believe that if the IoT module has default gateway set to you dont need to manually add the route on that device, only the engineering PC.

You could also possibly activate IP masquerading on the PLC.