Edge Computer(s) - Err 5 Certificate verification failed with apt update

When trying to update the software on the edge computer 752-9800 with apt update command, you will get an Err 5 not found … error. This is because of our expired docker GPG key. I wasn’t able to fix the broken certs, so I just uninstalled docker and re-install docker using these commands. If someone knows the command to update the key please post it!

These were done when logged into cockpit WBM with root account. If you do this with ssh using edge user, then you will need to add sudo to these commands.

(User docker to remove all containers, images and volumes if you’ve created any.)

apt purge -y docker docker.io wmdocker cockpit-docker
apt autoremove -y --purge docker docker.io wmdocker cockpit-docker

Now you can reinstall docker:

apt-get update
apt-get install apt-transport-https ca-certificates curl gnupg2 software-properties-common
curl -fsSL https://download.docker.com/linux/debian/gpg | sudo apt-key add -
 add-apt-repository "deb [arch=amd64] https://download.docker.com/linux/debian buster stable"
apt-get update
apt-get install docker-ce docker-ce-cli containerd.io
docker -v

Reference: https://phoenixnap.com/kb/how-to-install-docker-on-debian-10