Node Red on PFC200-8204 SD card

Hello Everyone,

I am trying to get node red installed on Wago-PFC200 8204 but i am getting an error while executing “docker pull nodered/node-red/” command about having no space on my device.

No space left

is there any way i can pull the docker image into my sd-card (or basically change the directory where it is extracting the image)?

info on devicer:
Filesystem Size Used Available Use% Mounted on
/dev/root 14.5G 353.1M 13.4G 3% /
devtmpfs 119.0M 56.0K 119.0M 0% /dev
none 119.5M 72.0K 119.5M 0% /tmp
none 119.5M 164.0K 119.4M 0% /media
none 4.0M 188.0K 3.8M 5% /var/log
none 119.5M 148.0K 119.4M 0% /var/run
none 119.5M 0 119.5M 0% /var/lock
none 119.5M 0 119.5M 0% /var/tmp
none 119.5M 0 119.5M 0% /sys/fs/cgroup
tmpfs 119.5M 68.0K 119.5M 0% /run
/dev/mmcblk0p1 16.0M 2.2M 13.8M 14% /boot/loader
none 119.5M 148.0K 119.4M 0% /var/run/netns
none 119.5M 164.0K 119.4M 0% /media/docker

I am using SD card as mass storage device and a bootable device as well. I successfully installed docker via using the CODESYS web page however i am not sure whether the docker is installed on the internal memory or not.

Goal is to get node-red installed on the Sd-card.

Please let me know if you have any idea to solve this. Thank you very much

Hello, when you created the SD image, did you select to use the full card size?

Please refer to the PFC100 SD Card boot how-to for more details.

How To: Using Docker on the PFC100 SD Card


I did not test it but please also look at default storage path “data-root” in /etc/docker/deamon.json.
It could be pointed to the SD card.


Hello thank you very much for your response. I am pretty sure i did selected the full card size for the image, because before that i was unable to even get the docker installed on the PFC via CODESYS as the Wago PFC has very low flash memory. Here is some information about my installed docker.

Never try this from a bootable SD card but have you tried changing the Docker root dir as suggests @WagoGrim ?
You should try creating a docker folder in /dev/root, then use it in the daemon.json file.
Restart the docker daemon

/etc/init.d/dockerd restart

Check if this ok :

docker system info --format '{{.DockerRootDir}}'

Then you will have to download again your images and so on.


Hello i did change my daemon.json file and pointing towards my SD card however i am still stuck at the same error. Here is details of my daemon.json file.

Hello, somehow by making change on the Daemon.json file, i was able to install node-red but however when i am launching wago PFC ip:1880 on web browser, it still does not connect.

I tried to run docker ps command and yes this is the information i have

root@PFC200-41E863:~ docker ps
6d4c710bd721 nodered/node-red “npm --no-update-not…” 5 minutes ago Up 3 minutes (unhealthy)>1880/tcp mynodered2
142963f0be57 nodered/node-red “npm --no-update-not…” 42 minutes ago Up 12 minutes (unhealthy) node-red

still not able to open node-red on the web-browser.

Hello, it appears you have two NodeRED containers running. I would stop them both using these commands;

docker rm -f 6d
docker rm -f 14
docker volume prune

then create a new container with the command;
docker run --restart unless-stopped -d --name node-red --network=host -v node_red_user_data:/data nodered/node-red


Thank you very much, i can access the node-red on 1880 port now. I still have a question that the in the command you mentioned above “–restart unless-stopped”, will it start nodered automatically on the system startup or i have to manually enable the container it is in via ssh root@IP ?


Great to hear! --restart unless-stopped will allow you to stop the container manually if you choose but will otherwise automatically start on power up. To manually stop this container, use the command:
docker stop node-red
and then to start it again use
docker start node-red