Wago cc100 modbus problem


I have problem with modbus serial port on wago cc 100. I follow all steps in wago guide
for rs485 on cc100.

My setup:
Wago cc 100 firmware: 03.09.07(21) (latest)
Nodered 3.0.1 docker image.
Modbus version 5.23.1.
Modbus device: IMI TA160 modbus valve actuator.

Guide i followed:

Here is error message i get from node-red console when doing a modbus read request:

./entrypoint.sh: line 14: 6 Segmentation fault /usr/local/bin/node $NODEOPTIONS node_modules/node-red/red.js --userDir /data $FLOWS

Im trying to read off register 0. Which should return me a value of 0. I have also tried to write to said register, but node-red still crash. I have also tried other registers to no avail.

I have to delete node-red-contrib-modbus to restart the flow.

There is 2 guides on how to use modbus rtu with nodered and wago cc100.
So far i followed this: Using RS485 port on CC100 with NodeRED

But maybe this guide is right one?

Works now. What i did was using this docker command :

docker run -d \
--name node-red \
--restart always \
--privileged=true \
--user=root \
-p 1880:1880 \
-v node_red_user_data:/data \
-v /dev/ttySTM1:/dev/serial \
1 Like