Wbm/runtime and visualization login

Hello everyone,

I’m trying to understand if it is this way or I can change it.

I’m making a PLC code and visualization screens, the ideia is to operate via webvisu some controls. So i made a code, made some screens and when i try it in my web browser, first it asks me to insert te user and password of the wbm/runtime of the plc (user: admin, password: wago by default), then i can acess my screens but I have to login again with the user and password that i created in the visualization user managment.

My question is: is there a way to disable this first login to the visualization screens (webvisu)? Or create another user/password for this first screen?

I have a PFC200 and a Edge Controller, both are working the same way.

Thanks in advance

Thanks

From the Web-Based Management, go to Configuration → Ports & Services → PLC Runtime Services. If you turn OFF the “Port Authentication” option, you will no longer be prompted for that initial login when you access a WebVisu.

3 Likes

Hi, you can also deactivate authentication for the visualisation only.
But then you have to adjust a config entry!
Login to the controller, e.g. via SFTP or SSH and set the entry “CallVisuServicesDirectly” to 1 in the file “/etc/codesys3.d/RtsCore.cfg”.

1 Like

Perfect, problem solved

Very thank you

1 Like

Very interesting, I will test it for knowledge purposes

Thank you either

1 Like

Hi Rafael, does yours doesnt have to key in like this after disabling the Port Authentication? Why mine still appear ? I have the same problem as yours.

They already told us what to do earlier. Here is the solution, uncheck the boxes as in the screenshot and try.

1 Like

Do you have user managment enabled? in your codesys project click Visualization Manager>User Managment and enable it, use legacy

Where exactly is the enable button?

seens users are already enabled, you just need to click “Convert to legacy” so you can create users in the new tab that will appear