750-8000 BC100 dataloger


270 / 5 000

Wyniki tłumaczenia


Hi, I’m struggling with saving a file using the CAA File library. When I open a file for writing/creating a file, I get “access denied” information. The question is, what permissions should I log in with (I log in with “admin”) to have writing access?

Hi, what path are you using ?
I think the BC100 path should be:

a: is the internal memory
s: is the SD card.

I have created folder a:\csv\ and I am trying to write in this folder.

file access is restricted to the SD card and the path A:\plc and of course to other folders below A:\plc. The csv folder should therefore be created in the A:\plc folder.

Thanks, I will try to use this folder and let you know.

BTW, I tried also to use panel TP600 (762-4203) as an SFTP destination for writing a file. I used a path:
sFileName: STRING:=‘sftp://:@<>[:<22>]/home/user/Test.txt’;
also with the same result as with BC100.
Is it the correct path?

First check the folder exist.
Next be sure the login you are using can write in this folder.
You can easily check by using a SSH client, using the same login to connect to the device and using nano or vi to create the file.