E!cockpit Error (PFC200-8204 GEN 1)

Hello everyone. Thanks for being supportive and helpful.

I am trying to connect to the WAGO-PFC200 8204 via e!cockpit. I run a network and it is able to detect the device and able to scan the modules, however when i am trying to connect it shows this specific error. My runtime environment is : eruntime (i double checked it on the CodeSYS webpage and via the wago ethernet setings page).


Please help. Thanks.

Hello, it might be caused by an outdated FW version. This can be checked on the web-based management.
Updating is typically done using an SD card with an image downloaded via WAGO’s github here:
> https://github.com/WAGO/pfc-firmware

Here is a tutorial for updating the Firmware;

Details on firmware and etc

Hello i believe, my firmware should be okay or i am not sure if i still require an upgrade on firmware or not but however one of the other thing i tried to get around was disabling “CodeSys gateway systray” and “Codesys Control Win Systray” from my taskbar and somehow it lets me connect to the Wago using e!cockpit but it leads me to an another error saying “Only limited connection to the device could be established, programming functions cannot be used”.

My end goal is that i can connect to e!cockpit without any issues and make it communicate with the node-red

You should not need to disable anything with the Gateway.
Have you have ever installed or uninstalled the Codesys IDE on this computer?
Also, has this device ever had the Codesys Control for PFC SL runtime installed on it?
Can you verify that e!COCKPIT is version

1 Like

You should uninstall the PFC200 SL runtime, it should reinstall the original e!COCKPIT runtime.
In CODESYS, in the menu “Tools/Update PFC200” fill in your Login credentials, the IP address and then click on Remove.
Then the RUN LED should blink green until your program is loaded and running.

1 Like

ecockpit version

This is my details about e!cockpit version and i never did install/uninstall on this computer. What it seems like i would maybe need a firmware re-install or i am on wrong direction? Please let me know,


Thank you very much. i actually ended up re-installing the firmware on wago and it did the job for me, i know it isn’t the right way but however my current firmware was configured to run on the CODESYS wbm and as i did the reset i was back to eruntime environment and was able to connect to the ecockpit.