E!cockpit - Issue adding a module to an existing project

Hi, I am occasional self taught user with a local installation of a PFC100 and field controllers communicating via modbus. I am using e!cockpit to program the system The project monitors alarm status and realtime values in a pumproom on our site. I have not updated or added to the system for about 3 years until this week when I went to add an 8 Channel DI module to the PFC100. I seemed to remember scanning modules when I added them previously but when I do this it sees the new module but there is no check box to ad the module. I can add all from scan result but this overwrites all modules on the PFC100 and removes all variable mapping. I then tried to add the module manually from the product catalogue and these appeared to work BUT in the local bus mapping view the fields are greyed out. In the physical install the module functions in that changing the state of the DI is registered on the unit itself. When I download the project to the PFC100 I get no error messages and the system works fine. I just cant map the inputs on the new DI module

Any advice would be greatly appreciated

When you add the new module manually while offline, do you see something like this:

If so, you should be able to directly add your new variable names to the Variable column. The Channel, Type, and Desc columns are always fixed and greyed out.

Make sure you are adding the module in the normal Device Structure window after opening the PFC detail. Don’t try to do it from within the window that appears after the “Scan” operation.

I hope this helps!


Hi Adam,

Thank for the taking the trouble to respond, it appears I did actually add the module as you described. I also managed to assign the variable names but I assumed wrongly I would add those variables to a visualisation lamp and expect it to update its state. Once I declared the variable in the program it worked nicely. DOH! Thanks Again!