Updating firmware through Shell


Is there a shell tool available to update the firmware of CC100 controllers?
I tried looking through the functions in /etc/config-tools, but I may be a bit out of my depth here.


my quick answer here is to look at both firmware update/restore in /etc/config-tools and the onboard rauc-tool. Unpack firmware .wup with e.g. 7zip and you get the .rauc-file. I did not test this in a while…

1 Like

Well, that solved my problems!
I was trying to get fwupdate to run using the wup file.

For anyone stumbling over this in the future:

  1. Download firmware and unpack WUP file
  2. Upload .raucb file to /tmp/fwupdate
  3. Navigate to /etc/config-tools and run:
  4. ./fwupdate activate
  5. ./fwupdate start (you should not have to specify a path when uploaded to /tmp/fwupdate)
  6. The update should now start running. To check the status, run ./fwupdate status
  7. Controller will restart
  8. When status is “unconfirmed” run ./fwupdate finish, and the update should be complete

It looks like step 4 might have to be done before step 2 if the directory doesn’t exist.